シェアする

  • このエントリーをはてなブックマークに追加

PowerConnectでVLANの設定をする

PowerConnect6248というものをバリバリ動かしている筆者です。

やっぱり、家庭では最低でも48ポート必要ですよね?

まあ、こいつのせいで電気代が掛かっているので対処法を考えていますが…

Ciscoのスイッチとは設定方法がすこし異なるところもあるので、今回はその部分を説明させていただきます。

広告

VLANの種類

VLANでの設定方法では以下の2つの種類があります。

  • accessポート
  • trunkポート

前半にaccessポート、後半にtrunkポートの設定方法について説明させていただきます。

Accessポートの設定編

Accessポートの設定方法を紹介します。

例として:1/g12ポートにVLAN100を割り当て、1/g13ポートのVLAN200と割り当てるとします。

config

vlan database
vlan 100
vlan 200
exit

interface ethernet 1/g12
switchport access vlan 100
exit

interface ethernet 1/g13
switchport access vlan 200
exit

上記のコードでaccessポートの設定ができます。

vlan databaseで使うVLANを設定しないと文句を言われるので、注意して下さい。

Trunkポートの設定編

そもそも、trunkポートとは複数のVLANを一つのインタフェースで実現する際に使用します。

それでは設定方法を紹介します。

例として、1/g1をVLAN 5,10,20とします。

config

vlan database
vlan 5
vlan 10
vlan 20
exit

interface ethernet 1/g1
switchport mode trunk
switchport trunk allowed vlan add 5,10,20
exit

このような感じで簡単に設定ができます。

switchport trunk allowedの部分では、Dell PowerConnectではall設定できないので、すべてのVLANを属したい場合でも、一つずつ記入する必要性があるので注意が必要です。

まとめ

このような感じで比較的簡単にできます。Cisco系のスイッチと少し異なる部分がありますが、慣れると問題ないです。

広告

シェアする

  • このエントリーをはてなブックマークに追加

フォローする

コメント

  1. 大面 雅博 より:

    powerconnect6248 を扱っているものです。
    貴殿のページを見つけ、質問させていただきました。

    IPv6の導入を考えておりまして、NGN網から割り当てられているIPv6アドレスをpowerconnect6248 を通したIP機器にも割り当てられるようにしたいと考えております。

    IPv4に関しては、VLANを切っており振り分けができておりますが、IPv6も同じ考え方でVLANを切ると、どうしてもうまくいきません。

    IPv6はVLANという考え方を外して、“ただのハブ扱い”のような位置づけはできないものなのでしょうか。

    分かりづらい質問内容かもしれませんが、当方もIPv6を勉強中でまだまだ分からないことだらけでして、質問の意図が見えづらいところかと思います。

    なにとぞお力添えをいただければと思います。

    • よねやん より:

      ご質問していただきまして、誠にありがとうございます。
      私自身も、正しい返答を出来ているかどうか厳しい部分もあると思いますので参考程度でよろしくお願いいたします。

      実のところ私も同じような問題に直面したので、その際の対処法を紹介します。
      しかし、この対処法では以下の点に問題があるので注意してください。
      |・DHCPv6サーバが必要
      |・それに伴って、androidではIPv6が降ってこない(DHCPv6に対応していないため)
      |・当方の環境ではwindowsupdate+ライセンス認証が通らないかもしれない

      ルータ側で/64のIPv6が割り当てされているため、それを無理矢理/80で各VLANに繋げるという方法でしました。
      また、ACLやファイアウォールを設定することで安全性を高めることが出来ます。
      しかし、この方法でするとandroid端末ではDHCPv6に対応していないということもあり、androidなどの端末を使用している時には注意が必要です。
      また、windowsupdate+ライセンス認証ができませんでしたが、IPv6で他のサービスがWebサーバに繋がっていることも考えるとプロバイダ側又はmicrosoftのサーバ側に問題がある可能性があるので出来ないとは断言出来ません。

      お役に立てたのか難しいところではありますが、これにて返答とさせていただきます。